Search found 5 matches

by IgoAtM
Fri Jul 13, 2018 7:32 am
Forum: AES Crypt
Topic: PHP > 5.2 aesCrypt complient class
Replies: 10
Views: 13555

Re: PHP > 5.2 aesCrypt complient class

Further update as introduced a bug on pre 5.3 php versions with an illegal bitwise op on const definition should have made no difference on post 5.4 the new version as attachment on post one has been updated to latest I hope now bug free I do not think these changes have made their way on to the git...
by IgoAtM
Thu Jul 12, 2018 8:05 pm
Forum: AES Crypt
Topic: PHP > 5.2 aesCrypt complient class
Replies: 10
Views: 13555

Re: PHP > 5.2 aesCrypt complient class

Time moves on and Personal Home Pages version 7.2 have removed mcrypt
so I have altered the script to use mycrypt in prior versions of PHP to 5.4 and
now use openssl on PHP post 5.4
New update is added in post one enjoy
by IgoAtM
Mon Feb 01, 2016 12:36 am
Forum: AES Crypt
Topic: PHP > 5.2 aesCrypt complient class
Replies: 10
Views: 13555

Re: PHP > 5.2 aesCrypt complient class

Had a very quick look at the windows line endings issue you raised and I am having problems duplicating the problem on my setup. running php (5.6.3) via a command line interface on my Linux OS I have inserted a windows formatted text document line endings 0x0d 0x0a and I have viewed the document pre...
by IgoAtM
Sun Jan 31, 2016 9:08 pm
Forum: AES Crypt
Topic: PHP > 5.2 aesCrypt complient class
Replies: 10
Views: 13555

Re: PHP > 5.2 aesCrypt complient class

Thanks for your bug response. It has been a long time since I last looked at the class so I will need to get backup to speed but will investigate
by IgoAtM
Wed Dec 11, 2013 9:05 am
Forum: AES Crypt
Topic: PHP > 5.2 aesCrypt complient class
Replies: 10
Views: 13555

PHP > 5.2 aesCrypt complient class

For any one that may be interested please find attached a php aesCrypt compliant class It was generated from the ground up by myself so I choose to release it under LGPL unless that is inconvenient in which case post me and I will discuss It was written for php 5.2+ but if anyone would like a retro ...