No video between Ekiga & Polycom Group500

Discussion related to implementation and use of the H.323 Plus H.323 stack at http://www.h323plus.org.
Post Reply
R4v3n
Posts: 4
Joined: Wed Dec 17, 2014 3:44 pm

No video between Ekiga & Polycom Group500

Post by R4v3n » Wed Dec 17, 2014 3:54 pm

Hello guys,
I have a recently acquired Polycom Group500 codec to make some videoconferencing. The idea is to be able to use SIP or H323, even trough Internet OR via ISDN.
I currently use a old Asterisk 1.4 for my Thomson ST2030 with 2 T0 lines with SIP.
I tried to use the old ooh323 from my Asterisk 1.4 between my ST2030 and the Group500 unit with H323 (Asterisk beeing a gateway) but sometimes it crashed.

So, I installed Asterisk 12 with H323plus 1.26.1 with Ptlib 2.10 in a VM to do some tests.
Now I'm able to make calls between Ekiga and the Group500, but I've only the audio.
I don't understand why, so maybe you can help me ? Why I don't get any video flow (both sides) while making a video call ?
Is there a special thing to activate or disable in ooh323.conf to make it works ?

Thank you very much !

R4v3n
Posts: 4
Joined: Wed Dec 17, 2014 3:44 pm

Re: No video between Ekiga & Polycom Group500

Post by R4v3n » Mon Dec 22, 2014 1:56 pm

Ok so I understood that I didn't pay attention to the configure result and I can see that H263/H263+ and H264 aren't enabled.
I'm trying to configure with them, I saw this topic : http://forums.packetizer.com/viewtopic.php?f=46&t=256 and I've the exact same problem. I tried to change h263_encode to ff_h263_encoder, but it's not better, and I compile under Ubuntu 12.04.

Can you patch this ? Or maybe give me a solution to make it compile with libavcodec/ffmpeg 0.10 from Ubuntu 12.04 ?

Thank you.

User avatar
willamowius
Posts: 39
Joined: Tue Sep 01, 2009 7:25 am
Contact:

Re: No video between Ekiga & Polycom Group500

Post by willamowius » Mon Dec 22, 2014 4:08 pm

FFMpeg is a moving target and we'll probably need help from the community to patch H323Plus to support every FFMpeg version out there.

Are you expecting Asterisk to convert a H.323 video call to a SIP video call ?

Last time I checked, none of the Asterisk channels was able to to that (regardless wether you are able to build the codecs in H323Plus or not).
Jan Willamowius
Founder of the GNU Gatekeeper Project
https://www.gnugk.org
https://www.willamowius.com (H.323 support)

R4v3n
Posts: 4
Joined: Wed Dec 17, 2014 3:44 pm

Re: No video between Ekiga & Polycom Group500

Post by R4v3n » Tue Dec 23, 2014 8:27 am

Hello willamowius, thanks for your answer.
No I'm not expecting to convert H.323 video call to SIP video call, I'm just trying to make H323 video call pass through asterisk from ISDN to my Polycom Group500 H.323 endpoint. Currently there's only the sound that works, and I don't understand why there's no video.

Thats why I'm asking for help ! :)

User avatar
willamowius
Posts: 39
Joined: Tue Sep 01, 2009 7:25 am
Contact:

Re: No video between Ekiga & Polycom Group500

Post by willamowius » Tue Dec 23, 2014 11:28 am

I don't think the Asterisk H.323 channels support any video.

Try the GNU Gatekeeper if you want to make H.323 calls with video.
Jan Willamowius
Founder of the GNU Gatekeeper Project
https://www.gnugk.org
https://www.willamowius.com (H.323 support)

R4v3n
Posts: 4
Joined: Wed Dec 17, 2014 3:44 pm

Re: No video between Ekiga & Polycom Group500

Post by R4v3n » Tue Dec 23, 2014 1:34 pm

Have you any tutorial to show how to configure GnuGK with Asterisk ? Thanks.

User avatar
willamowius
Posts: 39
Joined: Tue Sep 01, 2009 7:25 am
Contact:

Re: No video between Ekiga & Polycom Group500

Post by willamowius » Tue Dec 23, 2014 9:55 pm

You won't need Asterisk for your H.323 calls, but if you want too keep it for other purposes, you can take a look at my notes: http://www.gnugk.org/asterisk.html
Jan Willamowius
Founder of the GNU Gatekeeper Project
https://www.gnugk.org
https://www.willamowius.com (H.323 support)

Post Reply