GUI seems broken on Ubuntu

Discussion related to AES Crypt, the file encryption software for Windows, Linux, Mac, and Java.
Post Reply
rebolyte
Posts: 4
Joined: Fri Feb 12, 2016 2:07 am

GUI seems broken on Ubuntu

Post by rebolyte » Fri Feb 12, 2016 2:11 am

I am running Ubuntu 14.04 LTS with XFCE, and the AESCrypt GUI doesn't let me decrypt any files. It gives the error mentioned in this thread: viewtopic.php?f=72&t=530

However I know the file is not corrupted, as I can successfully decrypt it using aescrypt on the command line. Is there anything I can do to make the GUI work? I'm running AESCrypt 3.10 x64, the Linux binary downloaded from the website.

Thanks! AESCrypt is a great little tool.

User avatar
paulej
Posts: 524
Joined: Sun Aug 23, 2009 7:32 pm
Location: Research Triangle Park, NC, USA
Contact:

Re: GUI seems broken on Ubuntu

Post by paulej » Fri Feb 12, 2016 2:59 am

Most likely, the problem is related to a bug fixed last month, but not published on aescrypt.com that exists in the shell script that sits between the GUI and aescrypt binary.

If you're handy at the command line, replace aescrypt_gui with this file:
https://raw.githubusercontent.com/paule ... scrypt-gui

One of these days, I'll build a new binary package that includes this file. I've just been too busy.

rebolyte
Posts: 4
Joined: Fri Feb 12, 2016 2:07 am

Re: GUI seems broken on Ubuntu

Post by rebolyte » Wed Feb 17, 2016 1:05 am

Replacing that file did the trick. Thanks for the quick reply.

Post Reply