"Message have been altered or password is incorrect"

Discussion related to AES Crypt, the file encryption software for Windows, Linux, Mac, and Java.
dummy
Posts: 5
Joined: Tue Dec 22, 2015 6:28 pm

Re: "Message have been altered or password is incorrect"

Post by dummy » Tue Dec 22, 2015 6:41 pm

Hello

it happens also to me, but the firsts time it worked...don't what happens.

How can I solve it ?

To tell the truth I can not even encrypt because now I get
"Password doesnt match !!!"

But it works from command line

It has a buggy GUI....

I use chromixium.org as OS

Regards

User avatar
paulej
Posts: 522
Joined: Sun Aug 23, 2009 7:32 pm
Location: Research Triangle Park, NC, USA
Contact:

Re: "Message have been altered or password is incorrect"

Post by paulej » Thu Dec 24, 2015 2:30 pm

The error "message has been altered..." Is either due to entering the wrong password or a corrupt file.

The error saying the password doesn't match is odd. I assume you're getting that from the GUI? It might be a bug in the GUI script. I found one version of Linux that was producing error messages that caused this. It's been fixed, but a new version of the AES Crypt code hasn't been posted in binary form. Code change is in GitHub. Maybe I can build new binaries next week.

dummy
Posts: 5
Joined: Tue Dec 22, 2015 6:28 pm

Re: "Message have been altered or password is incorrect"

Post by dummy » Fri Dec 25, 2015 7:10 pm

Thank you

yes from the GUI.
Then if I restart the pc the passwords match.

As regarding the decrypting issue, I don't believe I typed a wrong password because I am sure 100%.
So for exclusion the file has been corrupted.

OK if the first case has been solved, I need to know what can cause the file corruption and why on decrypting phase, if it happens, we are not warned about it.
It creates anyway the file.
Or if as in the first case there is a scripting error, can it be caused by decrypting script as well ?

Regards

dummy
Posts: 5
Joined: Tue Dec 22, 2015 6:28 pm

Re: "Message have been altered or password is incorrect"

Post by dummy » Fri Dec 25, 2015 8:14 pm

In addition

may I ask you to add the item "AES Encrypit or Decrypt" in the context menu instead to let user open with an
application ?

It is more comfortable and understandable.

Thank you

dummy
Posts: 5
Joined: Tue Dec 22, 2015 6:28 pm

Re: "Message have been altered or password is incorrect"

Post by dummy » Fri Dec 25, 2015 8:22 pm

Sorry to insist

another problem is that if I try to decrypt the file.aes and I have a file with the same name of the encrypted file it will overwrites the clear one EVEN if the password is not correct.
I mean it open first the new stream and overwrites the clear file the test if the passwords match.

Can you avoid also this please ? That is first match the passwords then open the stream.

Thank you.

My best regards

User avatar
paulej
Posts: 522
Joined: Sun Aug 23, 2009 7:32 pm
Location: Research Triangle Park, NC, USA
Contact:

Re: "Message have been altered or password is incorrect"

Post by paulej » Sun Dec 27, 2015 7:18 am

Over-writing the output on Linux is intended, because that's the way I wanted it to work. On Windows, I check first, because Windows users tend to need more warnings. However, it would be reasonable to check for the existence of the output file when using the GUI. That would be consistent with Windows. It's on the to-do list.

The issue you have with the wrong password when using the GUI could be due to a bug in the front end script that gets called. There's a password prompt tool used that produces an error on some Linux releases and that error causes decryption failures. I'll try to fix that this week. The code is already in GitHub.

dummy
Posts: 5
Joined: Tue Dec 22, 2015 6:28 pm

Re: "Message have been altered or password is incorrect"

Post by dummy » Mon Dec 28, 2015 5:13 pm

Thank you very much for your willingness.

Our intent is replace windows for people who doesn't understand Linux and we should work as much as possible with GUI. That's our standard of quality and we donate if achieved.

So next week we are going to have a binary with the

corrected GUI
Warning for wrong password without delete the old file
Warning if there has been a corruption
?

Regards

Post Reply